add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

could a faulty psu be causing this?

tinyspoon
  • 28 months ago

Hi Guys,

Been having a mare of a time with this new build.

ROG STRIX Z370-I GAMING won't boot, and i have tried putting several fans in the CPU fan header or through the corsair fan pro link and neither work, the corsair pro doesn't even light up.. which makes me think its the PSU. but then when plugging in a keyboard to the mobo that lights up.. but the mouse didn't light up.

I think it might be the PSU but the RGBS on the behind the mobo light up and there is an orange light in the bottom corner. None of the top lights turn on though.

https://cdn.discordapp.com/attachments/400056961548419072/408031189081915422/image.jpg

Any ideas?

Comments

  • 28 months ago
  • 1 point

Orange light on ASUS Strix boards usually indicate that there is no SATA connection present. Try connecting a SATA SSD/HDD.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube