add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Power supply with parts list says 409 watts All I need !

Maide66
  • 2 months ago

Hello every I just finished my first build ever ... I built a Ryzen 5 ..2600 With an Asus x470 pro I have a rx 590 fat boy Pro vengeance 2x 8 go 3200 And a evga 600 watt psu

Every thing running super smooth but when I crank up power supply to max when I over clock using amD program it crashes and freezes and my battery back up beeps ... That’s obviously a sign the power supply is under powered .... or what do you all think that could be ?

ThNks

Comments

  • 2 months ago
  • 1 point
  • 2 months ago
  • 1 point

That’s the site to all my list

  • 2 months ago
  • 1 point

A crash may be not related to the PSU but on a wrong OCing adjustment.

  • 2 months ago
  • 1 point

my battery back up beeps

What UPS?

  • 2 months ago
  • 1 point

Get something like a CX 650.

[comment deleted by staff]

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube